Request Stats Report CSV Download Producing HTML Instead of CSV
Incident Report for BlazeMeter
Resolved
A hotfix was deployed and the issue has now been resolved
Posted Jun 16, 2024 - 19:09 PDT
Update
We are continuing to work on a fix for the issue. Though there is a workaround that can be used in the meantime. The Request Stats CSV can de downloaded in the proper format by making the following API call:

curl -X GET "https://a.blazemeter.com/api/v4/masters/{{{masterId}}}/reports/aggregatereport/data.csv" -o data.csv --user "{{{api_key}}}:{{{api_secret}}}"
Posted Jun 14, 2024 - 12:28 PDT
Identified
The issue has been identified and there is a fix in place on the testing environment being vetted before release. In the meantime, a workaround is that you can look in the artifacts.zip file from the logstab of your test results page.
Posted Jun 14, 2024 - 07:21 PDT
Update
We are still investigating the issue with the download of the Request Stats Reports. Performance tests, Mock Services and API Monitoring are all operational and functioning as expected.
Posted Jun 13, 2024 - 14:14 PDT
Update
We are continuing to investigate the issue with the download of the Request Stats Reports. Performance tests are operational and functioning as expected.
Posted Jun 13, 2024 - 09:13 PDT
Investigating
We are currently aware of an issue with downloading CSV files from the Request Stats Report. The issue has been escalated and is currently being investigated.
Posted Jun 13, 2024 - 08:12 PDT
This incident affected: Performance Testing.