Issue running Performance and Functional tests
Incident Report for BlazeMeter
Postmortem

What happened?

On May 19, 2020 - 13:43 PDT customers experienced a limitation in the system that prevented them from running Performance and Functional tests at the full scale of their entitlement.

Why did it happen?

The component of BlazeMeter that is responsible for providing the entitlement information for user accounts was unavailable. A precautionary mechanism kicked in that lowered the entitlement of all customers to a minimum capacity. While the main system of BlazeMeter was still available it was therefore not possible to run tests above certain limits (e.g. duration, number of virtual users). While our monitoring systems detected the issue early on, the alerts were not picked up immediately due to noise in the alerting system.

What measures are being taken to prevent it from happening again?

  • Improvements on the alerting system - cleaning up noisy alerts
  • Under consideration: reducing dependency on component that provides entitlement information & allowing manual override of fall back entitlements
Posted May 22, 2020 - 08:36 PDT

Resolved
The issue has been resolved. All tests should run normally now.
Posted May 19, 2020 - 14:47 PDT
Investigating
We are aware of an issue customers are having running performance and functional tests. We are investigating and will provide an update as soon as we have more information.
Posted May 19, 2020 - 13:43 PDT
This incident affected: Functional Testing and Performance Testing.