Issue when editing JMX Performance tests
Incident Report for BlazeMeter
Resolved
This incident has been resolved.
Posted Jul 10, 2023 - 20:32 PDT
Monitoring
A fix has been deployed to Production and is working as we have observed so far. We are continuing to monitor the situation for any reoccurrences of the issue. We will provide another update soon.
Posted Jul 10, 2023 - 13:23 PDT
Update
The issue editing performance tests affects new and old tests alike, whenever attempting to change something on the test a message in the lower-right corner "Failed to update test" is displayed. This issue is only with JMX tests where the threads value in the JMX itself is not defined by a literal integer but is defined by value like a UDV or property.

Work on the fix for this issue is still ongoing at this time. We will provide another update once we have more information.
Posted Jul 10, 2023 - 12:13 PDT
Identified
The issue editing performance tests affects new and old tests alike, whenever attempting to change something on the test a message in the lower-right corner "Failed to update test" is displayed. This issue is only with JMX tests where the threads value in the JMX itself is not defined by a literal integer but is defined by value like a UDV or property.

The issue has been identified and a fix is being implemented.
Posted Jul 10, 2023 - 09:44 PDT
Investigating
We are aware of an issue with BlazeMeter when editing Performance tests and are presently investigating. We will post an update here as soon as we have more information.
Posted Jul 10, 2023 - 08:52 PDT
This incident affected: Performance Testing.