BlazeMeter customers using OPL's may be seeing agents stuck in the Download status
Incident Report for BlazeMeter
Resolved
The incident has been resolved, The instructions in the Incident should be used to correct any agents that have been stuck in the Download state since Sunday August 21st.
Posted Aug 23, 2022 - 00:59 PDT
Monitoring
We have identified the issue with some of the on premise BlazeMeter agents that have auto updated enabled being in a stuck Download state since Sunday 21st August.

For any agents that are affected, and due to the nature of the failure, the only method to resolve this issue involves the agent being manually removed and redeployed using the procedure below :

Log in to the machine containing the agent and run the following command to list all the containers:
$ sudo docker ps -a

Remove the bzm-crane- container with the following command (You need the container ID from the previous step to run this command):
$ sudo docker rm -f

To remove the images for the BlazeMeter Crane, list out all the images on the machine using the following command:
$ sudo docker images

Identify the blazemeter/crane image id for version 3.6.8 and use the following command to delete the docker image
$sudo docker rmi

Download the latest version of the crane 3.6.9 by running this command
$sudo docker pull gcr.io/verdant-bulwark-278/blazemeter/crane:3.6.9

Tag the newly downloaded image
$sudo docker tag 3f96b07b8382 blazemeter/crane:3.6.9
$sudo docker tag 3f96b07b8382 blazemeter/crane:latest

Run the docker run command to start the agent with the relevant environment variables (if applicable for you) and wait for the agent to enter the idle state

If you have any additional issues please contact BlazeMeter Support.
Posted Aug 22, 2022 - 10:41 PDT
Investigating
We are aware of an issue with BlazeMeter agent that have auto updated enabled being in a stuck Download state since Sunday. We are working to resolve the issue. For further information please contact BlazeMeter support.
Posted Aug 22, 2022 - 04:19 PDT
This incident affected: BlazeMeter Platform.