Archived reports cannot be restored for Plans that allow unlimited reporting
Incident Report for BlazeMeter
Resolved
The issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Posted Oct 17, 2023 - 06:27 PDT
Investigating
The issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Posted Oct 17, 2023 - 06:11 PDT
Monitoring
The issue experienced by some customers has been addressed and functionality has been restored. We are currently monitoring the performance closely.

The next update will be provided as new information is available.
Posted Oct 17, 2023 - 05:47 PDT
Update
We have identified the cause of IMPACT experienced by some customers and we are currently working on a fix that will be deployed to production once it is verified.

The next update will be provided as new information is available.
Posted Oct 17, 2023 - 03:52 PDT
Update
We have identified the cause of IMPACT experienced by some customers and are currently working on a fix that will deployed.
The next update will be provided as new information is available.
Posted Oct 17, 2023 - 01:06 PDT
Update
We have identified the cause of IMPACT experienced by some customers and are currently working on mitigation.

The next update will be provided as new information is available.
Posted Oct 16, 2023 - 21:58 PDT
Identified
We have identified the cause of the inability of restoring archived reports experienced by some customers and are currently working on mitigation.

Customers with plans that allow unlimited report retention can continue to use the API to recover archived reports until this issue is finally resolved.

The next update will be provided as new information is available.
Posted Oct 16, 2023 - 17:47 PDT
Update
We are aware that some customers are not able to restore archived reports. We are still investigating the cause of this issue and will provide updates as new information becomes available.

It is still possible to use the API provided to manually restore any reports until the root cause of the issue is determined and a fix implemented.

All other aspects of the product are functioning as normal.
Posted Oct 16, 2023 - 15:41 PDT
Update
We are aware of an issue with restoring archived reports in BlazeMeter and are still investigating.

As a workaround, for accounts with Plans that allow unlimited reporting, archived reports can be manually restored by using the following API, until this issue is resolved:

curl -X 'POST' \
'https://a.blazemeter.com/api/v4/masters/{masterId}/restore-reports' \
-H 'accept: application/json' \
-d '' \
--user '{api_key}:{api_secret}'

where {masterId} is the number from the URL of the report as seen in the browser.

The next update will be provided as new information becomes available.
Posted Oct 16, 2023 - 14:13 PDT
Investigating
We are aware of an issue with BlazeMeter and are presently investigating.

As a workaround, for accounts with Plans that allow unlimited reporting, archived reports can be manually restored by using the following API, until this issue is resolved:

curl -X 'POST' \
'https://a.blazemeter.com/api/v4/masters/{masterId}/restore-reports' \
-H 'accept: application/json' \
-d '' \
--user '{api_key}:{api_secret}'

where {masterId} is the number from the URL of the report as seen in the browser.

We will post an update here as soon as we have more information.
Posted Oct 16, 2023 - 12:23 PDT
This incident affected: BlazeMeter Platform.