Slowness in BlazeMeter

Incident Report for BlazeMeter

Resolved

We have not observed anymore slowness in the UI as we've monitored the resolution of the issue. We are resolving the incident now.
Posted Sep 18, 2026 - 07:24 PDT

Monitoring

The R&D team have identified the cause of the slowness and have taken steps to improve the responsiveness of BlazeMeter. We are seeing improved performance in the UI from our side. We will continue to monitor the issue to ensure the slowness does not reoccur.
Posted Sep 18, 2026 - 06:17 PDT

Investigating

We are currently investigating an issue that is causing extreme slowness in the BlazeMeter UI. The R&D team is working to resolve the issue now and we will provide an update as soon as possible.
Posted Sep 18, 2026 - 06:09 PDT
This incident affected: BlazeMeter Platform.