Performance Test Results Delayed

Incident Report for BlazeMeter

Resolved

The issue with Performance Test results being delayed has been identified and fixed.
Posted Mar 09, 2025 - 11:53 PDT

Investigating

We are aware of some customers experiencing issues with Performance Test results being delayed. We are currently investigating the cause of this issue and will provide updates as new information becomes available.

All other aspects of the product are functioning as normal.
Posted Mar 09, 2025 - 10:20 PDT
This incident affected: Performance Testing.