All Systems Operational

BlazeMeter Platform ? Operational
Mock Services ? Operational
Functional Testing ? Operational
Performance Testing ? Operational
API Monitoring (Runscope) ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Apr 8, 2025

No incidents reported today.

Apr 7, 2025

No incidents reported.

Apr 6, 2025

No incidents reported.

Apr 5, 2025

No incidents reported.

Apr 4, 2025

No incidents reported.

Apr 3, 2025

No incidents reported.

Apr 2, 2025

No incidents reported.

Apr 1, 2025

No incidents reported.

Mar 31, 2025

No incidents reported.

Mar 30, 2025
Resolved - The incident has been resolved.
Mar 30, 12:34 PDT
Update - As of 18:15 UTC, the issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Mar 30, 11:27 PDT
Update - As of TIME_STAMP UTC, the issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Mar 30, 11:26 PDT
Investigating - We are currently investigating this issue.
Mar 30, 06:08 PDT
Mar 29, 2025

No incidents reported.

Mar 28, 2025

No incidents reported.

Mar 27, 2025

No incidents reported.

Mar 26, 2025

No incidents reported.

Mar 25, 2025
Resolved - This incident has been resolved.
Mar 25, 00:35 PDT
Monitoring - A fix has been implemented and we are monitoring the results.
Mar 25, 00:11 PDT
Investigating - We are currently investigating this issue.
Mar 24, 23:58 PDT